Skip to content

Plexim PLECS

Important: You have to be a student or faculty member in the University of Tennessee Department of Electrical Engineering and Computer Science to obtain a license.

Which Version Should You Use?

Before requesting the PLECS software, you need to know which version of PLECS you intend to use. The PLECS software comes in two forms:

  • PLECS Blockset
    This version of PLECS requires MATLAB and Simulink (part of OIT’s MATLAB license) to be installed on your machine. This is the preferred version for EECS students. This version should also match the version of MATLAB you have installed, e.g., 32-/64-bit.
  • PLECS Standalone
    As the name suggests, this version of PLECS does not require a MATLAB installation.
Once you have determined which version of PLECS you need, use the following guidelines to request the proper license.

Acquiring a License (On Campus)

If you require PLECS on a UT-owned computer, please send a request to ithelp@eecs.utk.edu containing the following information:

  • Your first and last name
  • Your UT NetID
  • The name of your computer, e.g., com1461

We will install the software and license for you.

Acquiring a License (Off Campus)

If you require PLECS on a personal computer, please send a request to ithelp@eecs.utk.edu containing the following information:

  • Your first and last name
  • Your UT NetID
  • The username on your computer that you will be use to run the software.
  • The MAC address of your computer
  • The type of PLECS you are installing (Blockset or Standalone)

Once you have received the license file, you will need to use it during the installation of your software. The PLECS User Manual, which contains installation instructions, is available on the PLECS website in the Downloads section along with the downloads for PLECS Blockset and Standalone.

 

The flagship campus of the University of Tennessee System and partner in the Tennessee Transfer Pathway.